Рейтинг@Mail.ru
Оглавление
Введение
1. Основные понятия и элементы окна Excel
2. Ввод и редактирование данных
3. Форматирование рабочего листа
4. Подготовка к печати документа Excel
5. Расчеты в Excel
6. Диаграммы в Excel
7. Работа со списками данных
8. Автоматическое подведение промежуточных итогов
9. Сводные таблицы

Microsoft Office Шаг за Шагом

Хотите быстро освоить Word, Excel и PowerPoint?
Все, что нужно для самостоятельного изучения

НАХОДИТСЯ ЗДЕСЬ >>



  Логическая функция ЕСЛИ

Логическая функция ЕСЛИ

Функция ЕСЛИ используется в случае, когда результат вычисления зависит от выполнения некоторого условия. Условие записывается в виде логического выражения.

Логическое выражение – это выражение, содержащее константы, формулы и ссылки на ячейки, соединенные знаками отношений:

>(больше);

<(меньше);

= (равно);

>= (больше или равно);

<= (меньше или равно);

> < (не равно).

Логическое выражение принимает одно из двух значений: истина (условие выполняется) или ложь (условие не выполняется).

Формат функции:

=ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь).

Текстовые константы, входящие в логическое выражение или другие аргументы функции, должны быть заключены в кавычки.

Рис. 5.8

Пример 1.

Задание: вычислить стоимость перевозок (тариф зависит от времени суток).

Выполнение.

  1. В ячейке С6 вызвать функцию ЕСЛИ.
  2. Заполнить поля аргументов функции, как показано на рисунке 5.9.
  3. Рис. 5.9

  4. Щелкнуть Ok (или нажать <Enter>).
  5. В строке формул отобразится функция:

    =ЕСЛИ(В6="день";A6*$B$2; А6*$B$3)

  6. Скопировать функцию вниз по столбцу, протянув маркер заполнения.

Рис. 5.10

Пример 2

Задание: вычислить премию в размере 10% от превышения плана продаж (если план не превышен, премия не назначается).

Функция для вычисления премии в ячейке С4 имеет вид:

=ЕСЛИ(B4>$A$2;(B4-$А$2)*10%;0)

Поля аргументов заполняются следующим образом:

Рис. 5.11

Вложенные логические функции

Функция ЕСЛИ допускает до 7 уровней вложения в качестве аргументов для конструирования более сложных проверок.

Рис. 5.12

Пример 3

Надбавка за стаж вычисляется по формуле:

Надбавка=
0, если стаж менее 5 лет;
10% от оклада, если стаж от 5 до 10 лет;
20% от оклада, если стаж не менее 10 лет.

Для расчета требуется проверка двух условий, следовательно, необходимо применить вложенную логическую функцию. Такая функция (в ячейке Е3) может выглядеть, например, следующим образом:

=ЕСЛИ(D3<5;0;ЕСЛИ(D3<10;C3*10%;C3*20%))

Функцию можно набрать с клавиатуры или воспользоваться Мастером функций:

  1. В ячейке Е3 вызвать функцию ЕСЛИ.
  2. В окне аргументов функции заполнить поля двух аргументов:
  3. Рис. 5.13

  4. Перейти в поле третьего аргумента (Значение_если_ложь) и щелкнуть на имени функции в левой части строки формул (там отображается имя функции ЕСЛИ, т.к. эта функция использовалась последней):

  5. Откроется новое окно аргументов функции с пустыми полями для ввода вложенной логической функции. Заполнить поля:

    Рис.5.14

  6. Щелкнуть Ok (или нажать <Enter>). В строке формул отобразится вложенная логическая функция

    =ЕСЛИ(D3<5;0;ЕСЛИ(D3<10;C3*10%;C3*20%)).

  7. Скопировать функцию на нижние ячейки, протянув маркер заполнения.

в начало



Стань УМНЕЕ компьютера!

http://vinogradonline.ru/ob/1188

Клуб на Миллион в месяц (СТАРТ)



Главная Windows 7 Windows XP Word 2003 Word 2007 Excel 2003 Excel 2007 Алгоритмы Статистика Принцип Парето Цифровые системы
управления

Copyright © 2008-2017
Ющик Е.В. e-mail: veta@comp5.ru

All Rights Reserved

Рейтинг@Mail.ru

Реклама: